summaryrefslogtreecommitdiffstats
path: root/vendor/proptest/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/proptest/Cargo.toml')
-rw-r--r--vendor/proptest/Cargo.toml19
1 files changed, 11 insertions, 8 deletions
diff --git a/vendor/proptest/Cargo.toml b/vendor/proptest/Cargo.toml
index 1d03f9c0b..e90054914 100644
--- a/vendor/proptest/Cargo.toml
+++ b/vendor/proptest/Cargo.toml
@@ -11,8 +11,9 @@
[package]
edition = "2018"
+rust-version = "1.60"
name = "proptest"
-version = "1.1.0"
+version = "1.2.0"
authors = ["Jason Lingle"]
exclude = [
"/gen-*.sh",
@@ -21,8 +22,8 @@ exclude = [
description = """
Hypothesis-like property-based testing and shrinking.
"""
-homepage = "https://altsysrq.github.io/proptest-book/proptest/index.html"
-documentation = "https://altsysrq.github.io/rustdoc/proptest/1.0.0/proptest/"
+homepage = "https://proptest-rs.github.io/proptest/proptest/index.html"
+documentation = "https://docs.rs/proptest/latest/proptest/"
readme = "README.md"
keywords = [
"property",
@@ -35,6 +36,13 @@ categories = ["development-tools::testing"]
license = "MIT/Apache-2.0"
repository = "https://github.com/proptest-rs/proptest"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.bit-set]
version = "0.5.0"
optional = true
@@ -55,10 +63,6 @@ version = "0.2.15"
features = ["libm"]
default-features = false
-[dependencies.quick-error]
-version = "2.0.0"
-optional = true
-
[dependencies.rand]
version = "0.8"
features = ["alloc"]
@@ -121,7 +125,6 @@ std = [
"rand/std",
"byteorder/std",
"lazy_static",
- "quick-error",
"regex-syntax",
"num-traits/std",
]