summaryrefslogtreecommitdiffstats
path: root/vendor/regex-syntax/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/regex-syntax/Cargo.toml')
-rw-r--r--vendor/regex-syntax/Cargo.toml18
1 files changed, 15 insertions, 3 deletions
diff --git a/vendor/regex-syntax/Cargo.toml b/vendor/regex-syntax/Cargo.toml
index 8d87f7a42..55c35ac96 100644
--- a/vendor/regex-syntax/Cargo.toml
+++ b/vendor/regex-syntax/Cargo.toml
@@ -10,9 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.60.0"
name = "regex-syntax"
-version = "0.6.28"
+version = "0.7.1"
authors = ["The Rust Project Developers"]
description = "A regular expression parser."
homepage = "https://github.com/rust-lang/regex"
@@ -21,8 +22,19 @@ readme = "README.md"
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/regex"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[features]
-default = ["unicode"]
+default = [
+ "std",
+ "unicode",
+]
+std = []
unicode = [
"unicode-age",
"unicode-bool",