summaryrefslogtreecommitdiffstats
path: root/vendor/rustc-rayon/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rustc-rayon/Cargo.toml')
-rw-r--r--vendor/rustc-rayon/Cargo.toml27
1 files changed, 7 insertions, 20 deletions
diff --git a/vendor/rustc-rayon/Cargo.toml b/vendor/rustc-rayon/Cargo.toml
index c2dc3e952..3e4092ead 100644
--- a/vendor/rustc-rayon/Cargo.toml
+++ b/vendor/rustc-rayon/Cargo.toml
@@ -10,9 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.59"
name = "rustc-rayon"
-version = "0.4.0"
+version = "0.5.0"
authors = [
"Niko Matsakis <niko@alum.mit.edu>",
"Josh Stone <cuviper@gmail.com>",
@@ -37,32 +38,18 @@ categories = ["concurrency"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/rustc-rayon"
-[dependencies.crossbeam-deque]
-version = "0.8.1"
+[lib]
+name = "rayon"
[dependencies.either]
version = "1.0"
default-features = false
-[dependencies.rayon-core]
-version = "0.4"
-package = "rustc-rayon-core"
-
-[dev-dependencies.docopt]
-version = "1"
-
-[dev-dependencies.lazy_static]
-version = "1"
+[dependencies.rustc-rayon-core]
+version = "0.5"
[dev-dependencies.rand]
version = "0.8"
[dev-dependencies.rand_xorshift]
version = "0.3"
-
-[dev-dependencies.serde]
-version = "1.0.85"
-features = ["derive"]
-
-[build-dependencies.autocfg]
-version = "1"