summaryrefslogtreecommitdiffstats
path: root/vendor/rustix/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rustix/Cargo.toml')
-rw-r--r--vendor/rustix/Cargo.toml37
1 files changed, 21 insertions, 16 deletions
diff --git a/vendor/rustix/Cargo.toml b/vendor/rustix/Cargo.toml
index b560499a8..c92852650 100644
--- a/vendor/rustix/Cargo.toml
+++ b/vendor/rustix/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.48"
name = "rustix"
-version = "0.37.6"
+version = "0.37.15"
authors = [
"Dan Gohman <dev@sunfishcode.online>",
"Jakub Konka <kubkon@jakubkonka.com>",
@@ -78,7 +78,7 @@ optional = true
package = "rustc-std-workspace-alloc"
[dependencies.bitflags]
-version = "1.2.1"
+version = "1.3.2"
[dependencies.compiler_builtins]
version = "0.1.49"
@@ -90,7 +90,7 @@ optional = true
package = "rustc-std-workspace-core"
[dependencies.io-lifetimes]
-version = "1.0.0"
+version = "1.0.10"
features = ["close"]
optional = true
default-features = false
@@ -104,15 +104,15 @@ default-features = false
version = "1.0"
[dev-dependencies.io-lifetimes]
-version = "1.0.0"
+version = "1.0.10"
features = ["close"]
default-features = false
[dev-dependencies.libc]
-version = "0.2.140"
+version = "0.2.142"
[dev-dependencies.libc_errno]
-version = "0.3.0"
+version = "0.3.1"
default-features = false
package = "errno"
@@ -190,7 +190,7 @@ use-libc = [
use-libc-auxv = ["libc"]
[target."cfg(all(any(target_os = \"android\", target_os = \"linux\"), any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\"))))))))".dependencies.linux-raw-sys]
-version = "0.3.0"
+version = "0.3.3"
features = [
"general",
"no_std",
@@ -201,18 +201,18 @@ default-features = false
version = "0.4"
[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.libc]
-version = "0.2.140"
+version = "0.2.142"
features = ["extra_traits"]
optional = true
[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.libc_errno]
-version = "0.3.0"
+version = "0.3.1"
optional = true
default-features = false
package = "errno"
[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.linux-raw-sys]
-version = "0.3.0"
+version = "0.3.3"
features = [
"general",
"errno",
@@ -221,12 +221,12 @@ features = [
]
default-features = false
-[target."cfg(any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))))".dependencies.libc]
-version = "0.2.140"
+[target."cfg(all(not(windows), any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\"))))))))".dependencies.libc]
+version = "0.2.142"
features = ["extra_traits"]
-[target."cfg(any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))))".dependencies.libc_errno]
-version = "0.3.0"
+[target."cfg(all(not(windows), any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\"))))))))".dependencies.libc_errno]
+version = "0.3.1"
default-features = false
package = "errno"
@@ -234,8 +234,13 @@ package = "errno"
version = "1.5.2"
optional = true
+[target."cfg(windows)".dependencies.libc_errno]
+version = "0.3.1"
+default-features = false
+package = "errno"
+
[target."cfg(windows)".dependencies.windows-sys]
-version = "0.45.0"
+version = "0.48.0"
features = [
"Win32_Foundation",
"Win32_Networking_WinSock",
@@ -244,4 +249,4 @@ features = [
]
[target."cfg(windows)".dev-dependencies.ctor]
-version = "0.1.21"
+version = "0.2.0"