summaryrefslogtreecommitdiffstats
path: root/vendor/rustix/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rustix/Cargo.toml')
-rw-r--r--vendor/rustix/Cargo.toml85
1 files changed, 44 insertions, 41 deletions
diff --git a/vendor/rustix/Cargo.toml b/vendor/rustix/Cargo.toml
index c92852650..dd40b2507 100644
--- a/vendor/rustix/Cargo.toml
+++ b/vendor/rustix/Cargo.toml
@@ -10,10 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.48"
+edition = "2021"
+rust-version = "1.63"
name = "rustix"
-version = "0.37.15"
+version = "0.38.1"
authors = [
"Dan Gohman <dev@sunfishcode.online>",
"Jakub Konka <kubkon@jakubkonka.com>",
@@ -78,7 +78,8 @@ optional = true
package = "rustc-std-workspace-alloc"
[dependencies.bitflags]
-version = "1.3.2"
+version = "2.3.3"
+default-features = false
[dependencies.compiler_builtins]
version = "0.1.49"
@@ -89,12 +90,6 @@ version = "1.0.0"
optional = true
package = "rustc-std-workspace-core"
-[dependencies.io-lifetimes]
-version = "1.0.10"
-features = ["close"]
-optional = true
-default-features = false
-
[dependencies.itoa]
version = "1.0.1"
optional = true
@@ -103,13 +98,8 @@ default-features = false
[dev-dependencies.flate2]
version = "1.0"
-[dev-dependencies.io-lifetimes]
-version = "1.0.10"
-features = ["close"]
-default-features = false
-
[dev-dependencies.libc]
-version = "0.2.142"
+version = "0.2.146"
[dev-dependencies.libc_errno]
version = "0.3.1"
@@ -117,13 +107,13 @@ default-features = false
package = "errno"
[dev-dependencies.memoffset]
-version = "0.8.0"
+version = "0.9.0"
[dev-dependencies.serial_test]
-version = "0.6"
+version = "2.0.0"
[dev-dependencies.tempfile]
-version = "3.4.0"
+version = "3.5.0"
[build-dependencies.cc]
version = "1.0.68"
@@ -131,47 +121,57 @@ optional = true
[features]
all-apis = [
+ "event",
"fs",
"io_uring",
"mm",
"net",
"param",
+ "pipe",
"process",
"procfs",
+ "pty",
"rand",
"runtime",
+ "system",
+ "stdio",
"termios",
"thread",
"time",
]
-all-impls = [
- "os_pipe",
- "fs-err",
-]
default = [
"std",
"use-libc-auxv",
]
+event = []
fs = []
-fs-err = ["io-lifetimes/fs-err"]
io_uring = [
"fs",
"net",
+ "linux-raw-sys/io_uring",
]
linux_4_11 = []
linux_latest = ["linux_4_11"]
mm = []
-net = []
-os_pipe = ["io-lifetimes/os_pipe"]
+net = [
+ "linux-raw-sys/net",
+ "linux-raw-sys/netlink",
+ "linux-raw-sys/if_ether",
+]
param = ["fs"]
-process = []
+pipe = []
+process = ["linux-raw-sys/prctl"]
procfs = [
"once_cell",
"itoa",
"fs",
]
+pty = [
+ "itoa",
+ "fs",
+]
rand = []
-runtime = []
+runtime = ["linux-raw-sys/prctl"]
rustc-dep-of-std = [
"core",
"alloc",
@@ -179,20 +179,23 @@ rustc-dep-of-std = [
"linux-raw-sys/rustc-dep-of-std",
"bitflags/rustc-dep-of-std",
]
-std = ["io-lifetimes"]
+std = ["bitflags/std"]
+stdio = []
+system = ["linux-raw-sys/system"]
termios = []
-thread = []
+thread = ["linux-raw-sys/prctl"]
time = []
use-libc = [
"libc_errno",
"libc",
]
-use-libc-auxv = ["libc"]
+use-libc-auxv = []
-[target."cfg(all(any(target_os = \"android\", target_os = \"linux\"), any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\"))))))))".dependencies.linux-raw-sys]
-version = "0.3.3"
+[target."cfg(all(any(target_os = \"android\", target_os = \"linux\"), any(rustix_use_libc, miri, not(all(target_os = \"linux\", target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\", target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\")))))))".dependencies.linux-raw-sys]
+version = "0.4.3"
features = [
"general",
+ "ioctl",
"no_std",
]
default-features = false
@@ -200,19 +203,19 @@ default-features = false
[target."cfg(all(criterion, not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dev-dependencies.criterion]
version = "0.4"
-[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.libc]
-version = "0.2.142"
+[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\", target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"))))".dependencies.libc]
+version = "0.2.146"
features = ["extra_traits"]
optional = true
-[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.libc_errno]
+[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\", target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"))))".dependencies.libc_errno]
version = "0.3.1"
optional = true
default-features = false
package = "errno"
-[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.linux-raw-sys]
-version = "0.3.3"
+[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\", target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"))))".dependencies.linux-raw-sys]
+version = "0.4.3"
features = [
"general",
"errno",
@@ -221,11 +224,11 @@ features = [
]
default-features = false
-[target."cfg(all(not(windows), any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\"))))))))".dependencies.libc]
-version = "0.2.142"
+[target."cfg(all(not(windows), any(rustix_use_libc, miri, not(all(target_os = \"linux\", target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\", target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\")))))))".dependencies.libc]
+version = "0.2.146"
features = ["extra_traits"]
-[target."cfg(all(not(windows), any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\"))))))))".dependencies.libc_errno]
+[target."cfg(all(not(windows), any(rustix_use_libc, miri, not(all(target_os = \"linux\", target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\", target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\")))))))".dependencies.libc_errno]
version = "0.3.1"
default-features = false
package = "errno"