summaryrefslogtreecommitdiffstats
path: root/vendor/security-framework/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/security-framework/Cargo.toml')
-rw-r--r--vendor/security-framework/Cargo.toml133
1 files changed, 133 insertions, 0 deletions
diff --git a/vendor/security-framework/Cargo.toml b/vendor/security-framework/Cargo.toml
new file mode 100644
index 000000000..08804452f
--- /dev/null
+++ b/vendor/security-framework/Cargo.toml
@@ -0,0 +1,133 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.60"
+name = "security-framework"
+version = "2.9.2"
+authors = [
+ "Steven Fackler <sfackler@gmail.com>",
+ "Kornel <kornel@geekhood.net>",
+]
+exclude = ["test/*"]
+description = "Security.framework bindings for macOS and iOS"
+homepage = "https://lib.rs/crates/security_framework"
+documentation = "https://docs.rs/security_framework"
+readme = "README.md"
+keywords = [
+ "iOS",
+ "TLS",
+ "SSL",
+ "crypto",
+ "keychain",
+]
+categories = [
+ "os::macos-apis",
+ "cryptography",
+ "api-bindings",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/kornelski/rust-security-framework"
+resolver = "1"
+
+[package.metadata.docs.rs]
+targets = [
+ "x86_64-apple-darwin",
+ "aarch64-apple-ios",
+]
+
+[[example]]
+name = "client"
+
+[[example]]
+name = "find_internet_password"
+
+[[example]]
+name = "set_internet_password"
+
+[dependencies.bitflags]
+version = "1.3.2"
+
+[dependencies.core-foundation]
+version = "0.9.3"
+
+[dependencies.core-foundation-sys]
+version = "0.8.3"
+
+[dependencies.libc]
+version = "0.2.139"
+
+[dependencies.log]
+version = "0.4.17"
+optional = true
+
+[dependencies.num-bigint]
+version = "0.4.3"
+optional = true
+
+[dependencies.security-framework-sys]
+version = "2.9.0"
+default-features = false
+
+[dev-dependencies.env_logger]
+version = "0.10.0"
+
+[dev-dependencies.hex]
+version = "0.4.3"
+
+[dev-dependencies.tempfile]
+version = "3.3.0"
+
+[dev-dependencies.time]
+version = "0.3.17"
+
+[dev-dependencies.x509-parser]
+version = "0.15.0"
+
+[features]
+OSX_10_10 = [
+ "OSX_10_9",
+ "security-framework-sys/OSX_10_10",
+]
+OSX_10_11 = [
+ "OSX_10_10",
+ "security-framework-sys/OSX_10_11",
+]
+OSX_10_12 = [
+ "OSX_10_11",
+ "security-framework-sys/OSX_10_12",
+]
+OSX_10_13 = [
+ "OSX_10_12",
+ "security-framework-sys/OSX_10_13",
+ "alpn",
+ "session-tickets",
+ "serial-number-bigint",
+]
+OSX_10_14 = [
+ "OSX_10_13",
+ "security-framework-sys/OSX_10_14",
+]
+OSX_10_15 = [
+ "OSX_10_14",
+ "security-framework-sys/OSX_10_15",
+]
+OSX_10_9 = ["security-framework-sys/OSX_10_9"]
+alpn = []
+default = ["OSX_10_9"]
+job-bless = []
+nightly = []
+serial-number-bigint = ["dep:num-bigint"]
+session-tickets = []
+
+[badges.maintenance]
+status = "looking-for-maintainer"