summaryrefslogtreecommitdiffstats
path: root/vendor/sha-1/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/sha-1/Cargo.toml')
-rw-r--r--vendor/sha-1/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/vendor/sha-1/Cargo.toml b/vendor/sha-1/Cargo.toml
new file mode 100644
index 000000000..3d8f91621
--- /dev/null
+++ b/vendor/sha-1/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "sha-1"
+version = "0.10.0"
+authors = ["RustCrypto Developers"]
+description = "SHA-1 hash function"
+documentation = "https://docs.rs/sha-1"
+readme = "README.md"
+keywords = ["crypto", "sha1", "hash", "digest"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/hashes"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[lib]
+name = "sha1"
+[dependencies.cfg-if]
+version = "1.0"
+
+[dependencies.digest]
+version = "0.10"
+
+[dependencies.sha1-asm]
+version = "0.5"
+optional = true
+[dev-dependencies.digest]
+version = "0.10"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.2"
+
+[features]
+asm = ["sha1-asm"]
+compress = []
+default = ["std"]
+force-soft = []
+std = ["digest/std"]
+[target."cfg(any(target_arch = \"aarch64\", target_arch = \"x86\", target_arch = \"x86_64\"))".dependencies.cpufeatures]
+version = "0.2"