summaryrefslogtreecommitdiffstats
path: root/vendor/sha1_smol/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/sha1_smol/Cargo.toml')
-rw-r--r--vendor/sha1_smol/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/vendor/sha1_smol/Cargo.toml b/vendor/sha1_smol/Cargo.toml
new file mode 100644
index 000000000..5441fed79
--- /dev/null
+++ b/vendor/sha1_smol/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "sha1_smol"
+version = "1.0.0"
+authors = ["Armin Ronacher <armin.ronacher@active-4.com>"]
+description = "Minimal dependency free implementation of SHA1 for Rust."
+keywords = ["sha1"]
+license = "BSD-3-Clause"
+repository = "https://github.com/mitsuhiko/sha1-smol"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.serde]
+version = "1.0"
+optional = true
+[dev-dependencies.openssl]
+version = "0.10"
+
+[dev-dependencies.rand]
+version = "0.4"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+std = []