summaryrefslogtreecommitdiffstats
path: root/vendor/similar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/similar/Makefile')
-rw-r--r--vendor/similar/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/vendor/similar/Makefile b/vendor/similar/Makefile
new file mode 100644
index 000000000..af6e83179
--- /dev/null
+++ b/vendor/similar/Makefile
@@ -0,0 +1,27 @@
+all: test
+
+build:
+ @cargo build --all-features
+
+doc:
+ @cargo doc --all-features
+
+test:
+ @cargo test
+ @cargo test --all-features
+ @cargo test --no-default-features
+ @cargo test --no-default-features --features bytes
+
+format:
+ @rustup component add rustfmt 2> /dev/null
+ @cargo fmt --all
+
+format-check:
+ @rustup component add rustfmt 2> /dev/null
+ @cargo fmt --all -- --check
+
+lint:
+ @rustup component add clippy 2> /dev/null
+ @cargo clippy
+
+.PHONY: all doc test format format-check lint