summaryrefslogtreecommitdiffstats
path: root/vendor/slab/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/slab/Cargo.toml')
-rw-r--r--vendor/slab/Cargo.toml53
1 files changed, 42 insertions, 11 deletions
diff --git a/vendor/slab/Cargo.toml b/vendor/slab/Cargo.toml
index 9e9fc4253..8823fb823 100644
--- a/vendor/slab/Cargo.toml
+++ b/vendor/slab/Cargo.toml
@@ -3,22 +3,53 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g. crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
+edition = "2018"
+rust-version = "1.31"
name = "slab"
-version = "0.4.2"
+version = "0.4.8"
authors = ["Carl Lerche <me@carllerche.com>"]
+exclude = ["/.*"]
description = "Pre-allocated storage for a uniform data type"
-homepage = "https://github.com/carllerche/slab"
-documentation = "https://docs.rs/slab/0.4.2/slab/"
readme = "README.md"
-keywords = ["slab", "allocator"]
-categories = ["memory-management", "data-structures"]
+keywords = [
+ "slab",
+ "allocator",
+ "no_std",
+]
+categories = [
+ "memory-management",
+ "data-structures",
+ "no-std",
+]
license = "MIT"
-repository = "https://github.com/carllerche/slab"
+repository = "https://github.com/tokio-rs/slab"
+
+[dependencies.serde]
+version = "1.0.95"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dev-dependencies.rustversion]
+version = "1"
+
+[dev-dependencies.serde]
+version = "1"
+features = ["derive"]
+
+[dev-dependencies.serde_test]
+version = "1"
+
+[build-dependencies.autocfg]
+version = "1"
+
+[features]
+default = ["std"]
+std = []