summaryrefslogtreecommitdiffstats
path: root/vendor/snap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/snap/Cargo.toml')
-rw-r--r--vendor/snap/Cargo.toml26
1 files changed, 18 insertions, 8 deletions
diff --git a/vendor/snap/Cargo.toml b/vendor/snap/Cargo.toml
index 8559a1e4b..12ad5ddeb 100644
--- a/vendor/snap/Cargo.toml
+++ b/vendor/snap/Cargo.toml
@@ -3,26 +3,35 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "snap"
-version = "1.0.5"
+version = "1.1.0"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
exclude = ["data/*"]
-description = "A pure Rust implementation of the Snappy compression algorithm. Includes\nstreaming compression and decompression.\n"
+description = """
+A pure Rust implementation of the Snappy compression algorithm. Includes
+streaming compression and decompression.
+"""
homepage = "https://github.com/BurntSushi/rust-snappy"
documentation = "https://docs.rs/snap"
readme = "README.md"
-keywords = ["snappy", "compress", "compression", "decompress", "decompression"]
+keywords = [
+ "snappy",
+ "compress",
+ "compression",
+ "decompress",
+ "decompression",
+]
license = "BSD-3-Clause"
repository = "https://github.com/BurntSushi/rust-snappy"
+
[profile.release]
debug = true
@@ -31,5 +40,6 @@ opt-level = 3
[lib]
bench = false
+
[dev-dependencies.doc-comment]
version = "0.3.1"