summaryrefslogtreecommitdiffstats
path: root/vendor/socket2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/socket2/Cargo.toml')
-rw-r--r--vendor/socket2/Cargo.toml49
1 files changed, 39 insertions, 10 deletions
diff --git a/vendor/socket2/Cargo.toml b/vendor/socket2/Cargo.toml
index 521c43c2c..3f1578ccb 100644
--- a/vendor/socket2/Cargo.toml
+++ b/vendor/socket2/Cargo.toml
@@ -12,28 +12,57 @@
[package]
edition = "2018"
name = "socket2"
-version = "0.4.1"
-authors = ["Alex Crichton <alex@alexcrichton.com>", "Thomas de Zeeuw <thomasdezeeuw@gmail.com>"]
-include = ["Cargo.toml", "LICENSE-APACHE", "LICENSE-MIT", "README.md", "src/**/*.rs"]
-description = "Utilities for handling networking sockets with a maximal amount of configuration\npossible intended.\n"
+version = "0.4.9"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Thomas de Zeeuw <thomasdezeeuw@gmail.com>",
+]
+include = [
+ "Cargo.toml",
+ "LICENSE-APACHE",
+ "LICENSE-MIT",
+ "README.md",
+ "src/**/*.rs",
+]
+description = """
+Utilities for handling networking sockets with a maximal amount of configuration
+possible intended.
+"""
homepage = "https://github.com/rust-lang/socket2"
documentation = "https://docs.rs/socket2"
readme = "README.md"
-keywords = ["io", "socket", "network"]
-categories = ["api-bindings", "network-programming"]
-license = "MIT/Apache-2.0"
+keywords = [
+ "io",
+ "socket",
+ "network",
+]
+categories = [
+ "api-bindings",
+ "network-programming",
+]
+license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/socket2"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
[package.metadata.playground]
features = ["all"]
[features]
all = []
+
[target."cfg(unix)".dependencies.libc]
-version = "0.2.96"
+version = "0.2.139"
+
[target."cfg(windows)".dependencies.winapi]
version = "0.3.9"
-features = ["handleapi", "ws2ipdef", "ws2tcpip"]
+features = [
+ "handleapi",
+ "ws2ipdef",
+ "ws2tcpip",
+]