summaryrefslogtreecommitdiffstats
path: root/vendor/url/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/url/Cargo.toml')
-rw-r--r--vendor/url/Cargo.toml47
1 files changed, 12 insertions, 35 deletions
diff --git a/vendor/url/Cargo.toml b/vendor/url/Cargo.toml
index 311354ca2..f70606edb 100644
--- a/vendor/url/Cargo.toml
+++ b/vendor/url/Cargo.toml
@@ -13,46 +13,32 @@
edition = "2018"
rust-version = "1.56"
name = "url"
-version = "2.4.0"
+version = "2.4.1"
authors = ["The rust-url developers"]
-include = [
- "src/**/*",
- "LICENSE-*",
- "README.md",
- "tests/**",
-]
+include = ["src/**/*", "LICENSE-*", "README.md", "tests/**"]
description = "URL library for Rust, based on the WHATWG URL Standard"
documentation = "https://docs.rs/url"
-readme = "README.md"
-keywords = [
- "url",
- "parser",
-]
-categories = [
- "parser-implementations",
- "web-programming",
- "encoding",
-]
+readme = "../README.md"
+keywords = ["url", "parser"]
+categories = ["parser-implementations", "web-programming", "encoding"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/servo/rust-url"
-
[package.metadata.docs.rs]
features = ["serde"]
+rustdoc-args = ["--generate-link-to-definition"]
[package.metadata.playground]
features = ["serde"]
[[test]]
-name = "debugger_visualizer"
-path = "tests/debugger_visualizer.rs"
-test = false
-required-features = ["debugger_visualizer"]
+name = "url_wpt"
+path = "tests/wpt.rs"
+harness = false
[[bench]]
name = "parse_url"
path = "benches/parse_url.rs"
harness = false
-
[dependencies.form_urlencoded]
version = "1.2.0"
@@ -66,15 +52,12 @@ version = "2.3.0"
version = "1.0"
features = ["derive"]
optional = true
-
[dev-dependencies.bencher]
version = "0.1"
-[dev-dependencies.debugger_test]
-version = "0.1"
-
-[dev-dependencies.debugger_test_parser]
-version = "0.1"
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
[dev-dependencies.serde_json]
version = "1.0"
@@ -83,9 +66,3 @@ version = "1.0"
debugger_visualizer = []
default = []
expose_internals = []
-
-[badges.appveyor]
-repository = "Manishearth/rust-url"
-
-[badges.travis-ci]
-repository = "servo/rust-url"