summaryrefslogtreecommitdiffstats
path: root/vendor/varisat/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/varisat/Cargo.toml')
-rw-r--r--vendor/varisat/Cargo.toml85
1 files changed, 85 insertions, 0 deletions
diff --git a/vendor/varisat/Cargo.toml b/vendor/varisat/Cargo.toml
new file mode 100644
index 000000000..a8030e6d5
--- /dev/null
+++ b/vendor/varisat/Cargo.toml
@@ -0,0 +1,85 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "varisat"
+version = "0.2.2"
+authors = ["Jannis Harder <me@jix.one>"]
+build = "build.rs"
+description = "A CDCL based SAT solver (library)"
+homepage = "https://jix.one/project/varisat/"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/jix/varisat"
+[dependencies.anyhow]
+version = "1.0.32"
+
+[dependencies.itoa]
+version = "0.4.4"
+
+[dependencies.leb128]
+version = "0.2.4"
+
+[dependencies.log]
+version = "0.4.6"
+
+[dependencies.ordered-float]
+version = "2.0.0"
+
+[dependencies.partial_ref]
+version = "0.3.1"
+
+[dependencies.rustc-hash]
+version = "1.1.0"
+
+[dependencies.serde]
+version = "1.0.91"
+features = ["derive"]
+
+[dependencies.thiserror]
+version = "1.0.20"
+
+[dependencies.varisat-checker]
+version = "=0.2.2"
+
+[dependencies.varisat-dimacs]
+version = "=0.2.2"
+
+[dependencies.varisat-formula]
+version = "=0.2.2"
+
+[dependencies.varisat-internal-macros]
+version = "=0.2.2"
+
+[dependencies.varisat-internal-proof]
+version = "=0.2.2"
+
+[dependencies.vec_mut_scan]
+version = "0.3.0"
+[dev-dependencies.env_logger]
+version = "0.7.1"
+
+[dev-dependencies.proptest]
+version = "0.10.1"
+
+[dev-dependencies.rand]
+version = "0.7.3"
+
+[dev-dependencies.tempfile]
+version = "3.0.8"
+
+[dev-dependencies.varisat-formula]
+version = "=0.2.2"
+features = ["proptest-strategies", "internal-testing"]
+[build-dependencies.anyhow]
+version = "1.0.32"