summaryrefslogtreecommitdiffstats
path: root/vendor/wasm-bindgen-shared
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/wasm-bindgen-shared')
-rw-r--r--vendor/wasm-bindgen-shared/.cargo-checksum.json1
-rw-r--r--vendor/wasm-bindgen-shared/Cargo.toml25
-rw-r--r--vendor/wasm-bindgen-shared/LICENSE-APACHE201
-rw-r--r--vendor/wasm-bindgen-shared/LICENSE-MIT25
-rw-r--r--vendor/wasm-bindgen-shared/build.rs35
-rw-r--r--vendor/wasm-bindgen-shared/src/lib.rs198
-rw-r--r--vendor/wasm-bindgen-shared/src/schema_hash_approval.rs16
7 files changed, 501 insertions, 0 deletions
diff --git a/vendor/wasm-bindgen-shared/.cargo-checksum.json b/vendor/wasm-bindgen-shared/.cargo-checksum.json
new file mode 100644
index 000000000..c5706ded3
--- /dev/null
+++ b/vendor/wasm-bindgen-shared/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"c031795d3a08a30d9bcf196926c495513cc1f074a63958da59bca326fc2ea023","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","build.rs":"1945abcbf05206be9463f60094b4363079f284781ed009feadb0137953826c26","src/lib.rs":"79a556de3784d8dff5e6c2928064892645aacb207f71fe82532cab8611fc0b4b","src/schema_hash_approval.rs":"1500c98ede5a6cb6a6e5eb592a67199bd64b09287c6fb0f94a2a2374bea5f8a9"},"package":"1c38c045535d93ec4f0b4defec448e4291638ee608530863b1e2ba115d4fff7f"} \ No newline at end of file
diff --git a/vendor/wasm-bindgen-shared/Cargo.toml b/vendor/wasm-bindgen-shared/Cargo.toml
new file mode 100644
index 000000000..8375843f9
--- /dev/null
+++ b/vendor/wasm-bindgen-shared/Cargo.toml
@@ -0,0 +1,25 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "wasm-bindgen-shared"
+version = "0.2.83"
+authors = ["The wasm-bindgen Developers"]
+links = "wasm_bindgen"
+description = """
+Shared support between wasm-bindgen and wasm-bindgen cli, an internal
+dependency.
+"""
+homepage = "https://rustwasm.github.io/wasm-bindgen/"
+documentation = "https://docs.rs/wasm-bindgen-shared"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rustwasm/wasm-bindgen/tree/master/crates/shared"
diff --git a/vendor/wasm-bindgen-shared/LICENSE-APACHE b/vendor/wasm-bindgen-shared/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/wasm-bindgen-shared/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/wasm-bindgen-shared/LICENSE-MIT b/vendor/wasm-bindgen-shared/LICENSE-MIT
new file mode 100644
index 000000000..39e0ed660
--- /dev/null
+++ b/vendor/wasm-bindgen-shared/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2014 Alex Crichton
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/wasm-bindgen-shared/build.rs b/vendor/wasm-bindgen-shared/build.rs
new file mode 100644
index 000000000..8e6ea1b03
--- /dev/null
+++ b/vendor/wasm-bindgen-shared/build.rs
@@ -0,0 +1,35 @@
+use std::collections::hash_map::DefaultHasher;
+use std::env;
+use std::hash::Hasher;
+use std::path::PathBuf;
+use std::process::Command;
+
+fn main() {
+ set_schema_version_env_var();
+
+ let rev = Command::new("git")
+ .arg("rev-parse")
+ .arg("HEAD")
+ .output()
+ .ok()
+ .map(|s| s.stdout)
+ .and_then(|s| String::from_utf8(s).ok());
+ if let Some(rev) = rev {
+ if rev.len() >= 9 {
+ println!("cargo:rustc-env=WBG_VERSION={}", &rev[..9]);
+ }
+ }
+}
+
+fn set_schema_version_env_var() {
+ let cargo_manifest_dir = env::var("CARGO_MANIFEST_DIR").expect(
+ "The `CARGO_MANIFEST_DIR` environment variable is needed to locate the schema file",
+ );
+ let schema_file = PathBuf::from(cargo_manifest_dir).join("src/lib.rs");
+ let schema_file = std::fs::read(schema_file).unwrap();
+
+ let mut hasher = DefaultHasher::new();
+ hasher.write(&schema_file);
+
+ println!("cargo:rustc-env=SCHEMA_FILE_HASH={}", hasher.finish());
+}
diff --git a/vendor/wasm-bindgen-shared/src/lib.rs b/vendor/wasm-bindgen-shared/src/lib.rs
new file mode 100644
index 000000000..f69d8f4a8
--- /dev/null
+++ b/vendor/wasm-bindgen-shared/src/lib.rs
@@ -0,0 +1,198 @@
+#![doc(html_root_url = "https://docs.rs/wasm-bindgen-shared/0.2")]
+
+#[cfg(test)]
+mod schema_hash_approval;
+
+// This gets changed whenever our schema changes.
+// At this time versions of wasm-bindgen and wasm-bindgen-cli are required to have the exact same
+// SCHEMA_VERSION in order to work together.
+pub const SCHEMA_VERSION: &str = "0.2.83";
+
+#[macro_export]
+macro_rules! shared_api {
+ ($mac:ident) => {
+ $mac! {
+ struct Program<'a> {
+ exports: Vec<Export<'a>>,
+ enums: Vec<Enum<'a>>,
+ imports: Vec<Import<'a>>,
+ structs: Vec<Struct<'a>>,
+ typescript_custom_sections: Vec<&'a str>,
+ local_modules: Vec<LocalModule<'a>>,
+ inline_js: Vec<&'a str>,
+ unique_crate_identifier: &'a str,
+ package_json: Option<&'a str>,
+ }
+
+ struct Import<'a> {
+ module: Option<ImportModule<'a>>,
+ js_namespace: Option<Vec<String>>,
+ kind: ImportKind<'a>,
+ }
+
+ enum ImportModule<'a> {
+ Named(&'a str),
+ RawNamed(&'a str),
+ Inline(u32),
+ }
+
+ enum ImportKind<'a> {
+ Function(ImportFunction<'a>),
+ Static(ImportStatic<'a>),
+ Type(ImportType<'a>),
+ Enum(ImportEnum),
+ }
+
+ struct ImportFunction<'a> {
+ shim: &'a str,
+ catch: bool,
+ variadic: bool,
+ assert_no_shim: bool,
+ method: Option<MethodData<'a>>,
+ structural: bool,
+ function: Function<'a>,
+ }
+
+ struct MethodData<'a> {
+ class: &'a str,
+ kind: MethodKind<'a>,
+ }
+
+ enum MethodKind<'a> {
+ Constructor,
+ Operation(Operation<'a>),
+ }
+
+ struct Operation<'a> {
+ is_static: bool,
+ kind: OperationKind<'a>,
+ }
+
+ enum OperationKind<'a> {
+ Regular,
+ Getter(&'a str),
+ Setter(&'a str),
+ IndexingGetter,
+ IndexingSetter,
+ IndexingDeleter,
+ }
+
+ struct ImportStatic<'a> {
+ name: &'a str,
+ shim: &'a str,
+ }
+
+ struct ImportType<'a> {
+ name: &'a str,
+ instanceof_shim: &'a str,
+ vendor_prefixes: Vec<&'a str>,
+ }
+
+ struct ImportEnum {}
+
+ struct Export<'a> {
+ class: Option<&'a str>,
+ comments: Vec<&'a str>,
+ consumed: bool,
+ function: Function<'a>,
+ method_kind: MethodKind<'a>,
+ start: bool,
+ }
+
+ struct Enum<'a> {
+ name: &'a str,
+ variants: Vec<EnumVariant<'a>>,
+ comments: Vec<&'a str>,
+ generate_typescript: bool,
+ }
+
+ struct EnumVariant<'a> {
+ name: &'a str,
+ value: u32,
+ comments: Vec<&'a str>,
+ }
+
+ struct Function<'a> {
+ arg_names: Vec<String>,
+ asyncness: bool,
+ name: &'a str,
+ generate_typescript: bool,
+ variadic: bool,
+ }
+
+ struct Struct<'a> {
+ name: &'a str,
+ fields: Vec<StructField<'a>>,
+ comments: Vec<&'a str>,
+ is_inspectable: bool,
+ generate_typescript: bool,
+ }
+
+ struct StructField<'a> {
+ name: &'a str,
+ readonly: bool,
+ comments: Vec<&'a str>,
+ generate_typescript: bool,
+ }
+
+ struct LocalModule<'a> {
+ identifier: &'a str,
+ contents: &'a str,
+ }
+ }
+ }; // end of mac case
+} // end of mac definition
+
+pub fn new_function(struct_name: &str) -> String {
+ let mut name = format!("__wbg_");
+ name.extend(struct_name.chars().flat_map(|s| s.to_lowercase()));
+ name.push_str("_new");
+ return name;
+}
+
+pub fn free_function(struct_name: &str) -> String {
+ let mut name = format!("__wbg_");
+ name.extend(struct_name.chars().flat_map(|s| s.to_lowercase()));
+ name.push_str("_free");
+ return name;
+}
+
+pub fn free_function_export_name(function_name: &str) -> String {
+ function_name.to_string()
+}
+
+pub fn struct_function_export_name(struct_: &str, f: &str) -> String {
+ let mut name = struct_
+ .chars()
+ .flat_map(|s| s.to_lowercase())
+ .collect::<String>();
+ name.push_str("_");
+ name.push_str(f);
+ return name;
+}
+
+pub fn struct_field_get(struct_: &str, f: &str) -> String {
+ let mut name = String::from("__wbg_get_");
+ name.extend(struct_.chars().flat_map(|s| s.to_lowercase()));
+ name.push_str("_");
+ name.push_str(f);
+ return name;
+}
+
+pub fn struct_field_set(struct_: &str, f: &str) -> String {
+ let mut name = String::from("__wbg_set_");
+ name.extend(struct_.chars().flat_map(|s| s.to_lowercase()));
+ name.push_str("_");
+ name.push_str(f);
+ return name;
+}
+
+pub fn version() -> String {
+ let mut v = env!("CARGO_PKG_VERSION").to_string();
+ if let Some(s) = option_env!("WBG_VERSION") {
+ v.push_str(" (");
+ v.push_str(s);
+ v.push_str(")");
+ }
+ return v;
+}
diff --git a/vendor/wasm-bindgen-shared/src/schema_hash_approval.rs b/vendor/wasm-bindgen-shared/src/schema_hash_approval.rs
new file mode 100644
index 000000000..4692a28c8
--- /dev/null
+++ b/vendor/wasm-bindgen-shared/src/schema_hash_approval.rs
@@ -0,0 +1,16 @@
+// Whenever the lib.rs changes, the SCHEMA_FILE_HASH environment variable will change and the
+// schema_version test below will fail.
+// Proceed as follows:
+//
+// If the schema in this library has changed then:
+// 1. Change this APPROVED_SCHEMA_FILE_HASH to the new hash.
+//
+// If the schema in this library has changed then:
+// 1. Bump the version in `crates/shared/Cargo.toml`
+// 2. Change the `SCHEMA_VERSION` in this library to this new Cargo.toml version
+const APPROVED_SCHEMA_FILE_HASH: &'static str = "17656911631008664055";
+
+#[test]
+fn schema_version() {
+ assert_eq!(env!("SCHEMA_FILE_HASH"), APPROVED_SCHEMA_FILE_HASH)
+}