summaryrefslogtreecommitdiffstats
path: root/vendor/windows-bindgen/readme.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/windows-bindgen/readme.md')
-rw-r--r--vendor/windows-bindgen/readme.md10
1 files changed, 5 insertions, 5 deletions
diff --git a/vendor/windows-bindgen/readme.md b/vendor/windows-bindgen/readme.md
index 3a54efce8..d1c29da2e 100644
--- a/vendor/windows-bindgen/readme.md
+++ b/vendor/windows-bindgen/readme.md
@@ -1,16 +1,16 @@
## Rust for Windows
-The [windows](https://crates.io/crates/windows) and [windows-sys](https://crates.io/crates/windows-sys) crates let you call any Windows API past, present, and future using code generated on the fly directly from the [metadata describing the API](https://github.com/microsoft/windows-rs/tree/master/crates/libs/metadata/default) and right into your Rust package where you can call them as if they were just another Rust module. The Rust language projection follows in the tradition established by [C++/WinRT](https://github.com/microsoft/cppwinrt) of building language projections for Windows using standard languages and compilers, providing a natural and idiomatic way for Rust developers to call Windows APIs.
+The [windows](https://crates.io/crates/windows) and [windows-sys](https://crates.io/crates/windows-sys) crates let you call any Windows API past, present, and future using code generated on the fly directly from the [metadata describing the API](https://github.com/microsoft/windows-rs/tree/master/crates/libs/bindgen/default) and right into your Rust package where you can call them as if they were just another Rust module. The Rust language projection follows in the tradition established by [C++/WinRT](https://github.com/microsoft/cppwinrt) of building language projections for Windows using standard languages and compilers, providing a natural and idiomatic way for Rust developers to call Windows APIs.
* [Getting started](https://kennykerr.ca/rust-getting-started/)
-* [Samples](https://github.com/microsoft/windows-rs/tree/0.48.0/crates/samples)
+* [Samples](https://github.com/microsoft/windows-rs/tree/0.51.1/crates/samples)
* [Releases](https://github.com/microsoft/windows-rs/releases)
Start by adding the following to your Cargo.toml file:
```toml
[dependencies.windows]
-version = "0.48"
+version = "0.51"
features = [
"Data_Xml_Dom",
"Win32_Foundation",
@@ -38,9 +38,9 @@ fn main() -> Result<()> {
unsafe {
let event = CreateEventW(None, true, false, None)?;
- SetEvent(event).ok()?;
+ SetEvent(event)?;
WaitForSingleObject(event, 0);
- CloseHandle(event).ok()?;
+ CloseHandle(event)?;
MessageBoxA(None, s!("Ansi"), s!("Caption"), MB_OK);
MessageBoxW(None, w!("Wide"), w!("Caption"), MB_OK);