summaryrefslogtreecommitdiffstats
path: root/vendor/yoke/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/yoke/Cargo.toml')
-rw-r--r--vendor/yoke/Cargo.toml83
1 files changed, 83 insertions, 0 deletions
diff --git a/vendor/yoke/Cargo.toml b/vendor/yoke/Cargo.toml
new file mode 100644
index 000000000..d8629127d
--- /dev/null
+++ b/vendor/yoke/Cargo.toml
@@ -0,0 +1,83 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "yoke"
+version = "0.6.2"
+authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "Abstraction allowing borrowed data to be carried along with the backing data it borrows from"
+keywords = [
+ "zerocopy",
+ "serialization",
+ "lifetime",
+ "borrow",
+ "self-referential",
+]
+categories = [
+ "data-structures",
+ "memory-management",
+ "caching",
+ "no-std",
+]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.stable_deref_trait]
+version = "1.2.0"
+default-features = false
+
+[dependencies.yoke-derive]
+version = "0.6.0"
+optional = true
+
+[dependencies.zerofrom]
+version = "0.1.0"
+optional = true
+default-features = false
+
+[dev-dependencies.bincode]
+version = "1.3.3"
+
+[dev-dependencies.serde]
+version = "1.0.125"
+
+[features]
+alloc = [
+ "stable_deref_trait/alloc",
+ "serde/alloc",
+ "zerofrom/alloc",
+]
+default = [
+ "alloc",
+ "zerofrom",
+]
+derive = [
+ "yoke-derive",
+ "zerofrom/derive",
+]