summaryrefslogtreecommitdiffstats
path: root/testprogs/win32/midltests/Makefile.tcp
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:20:00 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:20:00 +0000
commit8daa83a594a2e98f39d764422bfbdbc62c9efd44 (patch)
tree4099e8021376c7d8c05bdf8503093d80e9c7bad0 /testprogs/win32/midltests/Makefile.tcp
parentInitial commit. (diff)
downloadsamba-8daa83a594a2e98f39d764422bfbdbc62c9efd44.tar.xz
samba-8daa83a594a2e98f39d764422bfbdbc62c9efd44.zip
Adding upstream version 2:4.20.0+dfsg.upstream/2%4.20.0+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testprogs/win32/midltests/Makefile.tcp')
-rw-r--r--testprogs/win32/midltests/Makefile.tcp22
1 files changed, 22 insertions, 0 deletions
diff --git a/testprogs/win32/midltests/Makefile.tcp b/testprogs/win32/midltests/Makefile.tcp
new file mode 100644
index 0000000..19c1f11
--- /dev/null
+++ b/testprogs/win32/midltests/Makefile.tcp
@@ -0,0 +1,22 @@
+INCLUDES=-I
+CFLAGS=$(INCLUDES) -Zi -D_WIN32_WINNT=0x610
+LIBS=rpcrt4.lib ws2_32.lib
+
+all: midltests_tcp.exe
+
+clean:
+ del *~ *.obj *.exe midltests.h midltests_s.c midltests_c.c
+
+MIDL_ARGS=/target NT60 /prefix client cli_ /prefix server srv_ /prefix switch swi_
+midltests.h midltests_s.c midltests_c.c: midltests.idl midltests.acf
+ midl $(MIDL_ARGS) /acf midltests.acf midltests.idl
+
+MIDLTESTS_OBJ = midltests_tcp.obj midltests_s.obj midltests_c.obj midltests_marshall.obj utils.obj
+midltests_tcp.exe: $(MIDLTESTS_OBJ)
+ $(CC) -o midltests_tcp.exe $(MIDLTESTS_OBJ) $(LIBS)
+
+midltests_tcp.obj: midltests.h midltests.idl
+
+midltests_tcp.obj: midltests.h midltests.idl midltests_tcp.c
+midltests_marshall.obj: midltests.h midltests_marshall.c
+utils.obj: midltests.h utils.c