summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 2 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 1142fe1..cbc2168 100755
--- a/debian/rules
+++ b/debian/rules
@@ -41,6 +41,7 @@ with-ceph =
with-snapper =
config-args = \
+ --vendor-name=${DEB_VENDOR}-${DEB_VERSION_UPSTREAM_REVISION} \
--prefix=/usr \
--enable-fhs \
--sysconfdir=/etc \
@@ -90,7 +91,7 @@ endif
# Ubuntu i386 binary compatibility only effort: Disable some i386 packages and modules
ifeq (${DEB_VENDOR}-${DEB_HOST_ARCH}, Ubuntu-i386)
-omit-pkgs += ctdb libpam-winbind samba samba-testsuite samba-vfs-modules
+omit-pkgs += ctdb libpam-winbind samba samba-ad-dc samba-testsuite samba-vfs-modules
endif
ifneq (,$(filter armel mipsel m68k powerpc sh4,${DEB_HOST_ARCH}))
@@ -162,12 +163,6 @@ install install-arch install-indep: %:
configure: bin/configured.stamp
.PHONY: configure
bin/configured.stamp:
-# branding
- if [ ! -f VERSION.orig ]; then \
- mv VERSION VERSION.orig; \
- sed -r -e 's/^(SAMBA_VERSION_VENDOR_SUFFIX).*/\1=${DEB_VENDOR}/' \
- VERSION.orig > VERSION; \
- fi
CC="${CC}" CPP="${CPP}" LD="${LD}" PKGCONFIG="${PKG_CONFIG}" \
CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
PYTHON=python3 PYTHON_CONFIG=${DEB_HOST_MULTIARCH}-python3-config \
@@ -392,7 +387,6 @@ endif
clean:
# see also debian/clean
dh_clean bin/ testbuild/
- [ ! -f VERSION.orig ] || mv -f VERSION.orig VERSION
ifneq (,${with_mitkrb5})
[ ! -d third_party/heimdal-build-with-mitkrb5 ] || \
mv third_party/heimdal-build-with-mitkrb5 third_party/heimdal