summaryrefslogtreecommitdiffstats
path: root/examples/pcap2nbench/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/pcap2nbench/Makefile')
-rw-r--r--examples/pcap2nbench/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/examples/pcap2nbench/Makefile b/examples/pcap2nbench/Makefile
new file mode 100644
index 0000000..c1221b3
--- /dev/null
+++ b/examples/pcap2nbench/Makefile
@@ -0,0 +1,33 @@
+###############################################################################
+##
+## pcap2nbench - Converts libpcap network traces to nbench input
+## Copyright (C) 2004 Jim McDonough <jmcd@us.ibm.com>
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 3 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, see <http://www.gnu.org/licenses/>.
+##
+## Written by Anthony Liguori <aliguori@us.ibm.com>
+##
+###############################################################################
+
+OBJ=main.o ethernet.o ip.o tcp.o smb.o ntcreateandxrequest.o readandxrequest.o writeandxrequest.o closerequest.o ntcreateandxresponse.o
+PROG=pcap2nbench
+CXXFLAGS=-g -Wall
+LDFLAGS=
+LIB=-lpcap
+
+$(PROG): $(OBJ)
+ $(CXX) -o $(PROG) $(CXXFLAGS) $(OBJ) $(LDFLAGS) $(LIB)
+
+clean:
+ $(RM) $(OBJ) $(PROG)