summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:46:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:46:56 +0000
commit8e79ad9f544d1c4a0476e0d96aef0496ca7fc741 (patch)
treecda1743f5820600fd8c638ac7f034f917ac8c381 /Makefile.am
parentInitial commit. (diff)
downloadsbuild-8e79ad9f544d1c4a0476e0d96aef0496ca7fc741.tar.xz
sbuild-8e79ad9f544d1c4a0476e0d96aef0496ca7fc741.zip
Adding upstream version 0.85.6.upstream/0.85.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..537c109
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,49 @@
+# sbuild Makefile template
+#
+#
+# Copyright © 2004-2007 Roger Leigh <rleigh@debian.org>
+#
+# sbuild is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# sbuild is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+#
+#####################################################################
+
+include $(top_srcdir)/scripts/global.mk
+
+SUBDIRS = bin tools configs etc lib man db test
+
+dist-hook:
+# Remove junk from the generated tarball.
+ $(FIND) $(distdir) -name '.*' -print | $(XARGS) xargs $(RM) -rf
+ $(FIND) $(distdir) -name '#*' -print | $(XARGS) $(RM) -rf
+ $(FIND) $(distdir) -name '*~' -print | $(XARGS) $(RM) -rf
+
+EXTRA_DIST = \
+ bootstrap \
+ lisp \
+ scripts/git-tag-release \
+ ChangeLog-buildd \
+ HACKING \
+ Makefile-buildd \
+ NEWS-buildd \
+ README.buildd-admin \
+ README.chroot-building
+
+ps:
+ $(MAKE) -C doc sbuild.ps
+
+pdf:
+ $(MAKE) -C doc sbuild.pdf
+
+.PHONY: ps pdf