summaryrefslogtreecommitdiffstats
path: root/db/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'db/Makefile.am')
-rw-r--r--db/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/db/Makefile.am b/db/Makefile.am
new file mode 100644
index 0000000..4466a3d
--- /dev/null
+++ b/db/Makefile.am
@@ -0,0 +1,50 @@
+# sbuild Makefile template
+#
+#
+# Copyright © 2004-2009 Roger Leigh <rleigh@debian.org>
+#
+# sbuild is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# sbuild is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+#
+#####################################################################
+
+include $(top_srcdir)/scripts/global.mk
+
+sqldir = $(datadir)/wanna-build/postgresql/install
+
+SQL = \
+ archive-data.sql \
+ archive.sql \
+ build-data.sql \
+ build.sql \
+ functions.sql \
+ install.sql \
+ language.sql \
+ schema.sql
+
+sql_DATA = \
+ $(SQL) \
+ db.sql
+
+db.sql: db.sql.in
+ sqlpath=$$(echo "$(sqldir)"); \
+ sqlpath=$$(echo "$$sqlpath" | sed -e 's/\//\\\//g'); \
+ sed "s,SQL_PATHNAME,$$sqlpath,g" $< >$@
+
+CLEANFILES = \
+ db.sql
+
+EXTRA_DIST = \
+ $(SQL) \
+ db.sql.in