summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:56:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:56:50 +0000
commit6637322c8ab1c5ff80a2b6ca59c9ba1d40aeba2c (patch)
tree04e41667e9eae835f5d88bda4f6d3f5c2664de01 /Makefile
parentInitial commit. (diff)
downloadsphinx-rtd-theme-6637322c8ab1c5ff80a2b6ca59c9ba1d40aeba2c.tar.xz
sphinx-rtd-theme-6637322c8ab1c5ff80a2b6ca59c9ba1d40aeba2c.zip
Adding upstream version 2.0.0+dfsg.upstream/2.0.0+dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..5af15e7
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,19 @@
+SHELL := /bin/bash
+CWD := $(shell cd -P -- '$(shell dirname -- "$0")' && pwd -P)
+
+docker-images:
+ docker-compose build
+
+docker-npm-build:
+ rm -f .container_id
+ docker-compose run -d sphinx_rtd_theme build > .container_id
+ sleep 1s
+ docker container wait "$(shell cat .container_id)"
+ docker cp "$(shell cat .container_id):/project/sphinx_rtd_theme" .
+ docker cp "$(shell cat .container_id):/project/package-lock.json" .
+ @echo "Done building"
+
+docker-npm-dev:
+ docker-compose run sphinx_rtd_theme dev
+
+docker-build-all: docker-images docker-npm-build