summaryrefslogtreecommitdiffstats
path: root/debian/patches/do-not-override-build-commands.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/do-not-override-build-commands.patch')
-rw-r--r--debian/patches/do-not-override-build-commands.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/do-not-override-build-commands.patch b/debian/patches/do-not-override-build-commands.patch
new file mode 100644
index 0000000..ca70751
--- /dev/null
+++ b/debian/patches/do-not-override-build-commands.patch
@@ -0,0 +1,21 @@
+From: Dmitry Shachnev <mitya57@debian.org>
+Date: Sun, 23 Aug 2020 18:04:51 +0300
+Subject: Do not override Python build commands
+
+We do not use webpack in debian packaging.
+---
+ setup.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 36a2a98..e42f539 100644
+--- a/setup.py
++++ b/setup.py
+@@ -90,7 +90,5 @@ setup(
+ cmdclass={
+ 'update_translations': UpdateTranslationsCommand,
+ 'transifex': TransifexCommand,
+- 'build_assets': WebpackBuildCommand,
+- 'watch': WebpackDevelopCommand,
+ },
+ )