summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:11:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:11:17 +0000
commitee67eaf33c676bef4f5a516d583f0e2245ec7235 (patch)
treede98f46e94f89158c438e6843ce88856ecd9412d
parentReleasing progress-linux version 7.2.6-6~progress7.99u1. (diff)
downloadsphinx-ee67eaf33c676bef4f5a516d583f0e2245ec7235.tar.xz
sphinx-ee67eaf33c676bef4f5a516d583f0e2245ec7235.zip
Merging debian version 7.2.6-7.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/python_3.12.3.diff25
-rw-r--r--debian/patches/series1
3 files changed, 32 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5593a9b..7224829 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+sphinx (7.2.6-7) unstable; urgency=medium
+
+ * Backport upstream patch to fix test failure with Python 3.12.3.
+
+ -- Dmitry Shachnev <mitya57@debian.org> Fri, 10 May 2024 21:42:01 +0300
+
sphinx (7.2.6-6~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/patches/python_3.12.3.diff b/debian/patches/python_3.12.3.diff
new file mode 100644
index 0000000..5df6857
--- /dev/null
+++ b/debian/patches/python_3.12.3.diff
@@ -0,0 +1,25 @@
+From: James Addison <55152140+jayaddison@users.noreply.github.com>
+Date: Fri, 8 Mar 2024 10:58:04 +0000
+Subject: [tests] reflect changes to Enum signature in Python 3.12.3 (#12054)
+
+(cherry picked from commit 5523c9bbe4d1415777669330411d4f00ad802f18)
+---
+ tests/test_ext_autodoc.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/tests/test_ext_autodoc.py b/tests/test_ext_autodoc.py
+index 7062763..5f63214 100644
+--- a/tests/test_ext_autodoc.py
++++ b/tests/test_ext_autodoc.py
+@@ -1407,7 +1407,10 @@ def test_enum_class(app):
+ options = {"members": None}
+ actual = do_autodoc(app, 'class', 'target.enums.EnumCls', options)
+
+- if sys.version_info[:2] >= (3, 12):
++ if sys.version_info[:3] >= (3, 12, 3):
++ args = ('(value, names=<not given>, *values, module=None, '
++ 'qualname=None, type=None, start=1, boundary=None)')
++ elif sys.version_info[:2] >= (3, 12):
+ args = ('(value, names=None, *values, module=None, '
+ 'qualname=None, type=None, start=1, boundary=None)')
+ elif sys.version_info[:2] >= (3, 11):
diff --git a/debian/patches/series b/debian/patches/series
index fe0e669..c51c13a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -9,3 +9,4 @@ intersphinx_local.diff
support_old_search_indexes.diff
docutils_manpage_macros.diff
python_3.11.7.diff
+python_3.12.3.diff