summaryrefslogtreecommitdiffstats
path: root/sphinx/templates/quickstart/Makefile.new_t
diff options
context:
space:
mode:
Diffstat (limited to 'sphinx/templates/quickstart/Makefile.new_t')
-rw-r--r--sphinx/templates/quickstart/Makefile.new_t21
1 files changed, 21 insertions, 0 deletions
diff --git a/sphinx/templates/quickstart/Makefile.new_t b/sphinx/templates/quickstart/Makefile.new_t
new file mode 100644
index 0000000..1a52757
--- /dev/null
+++ b/sphinx/templates/quickstart/Makefile.new_t
@@ -0,0 +1,21 @@
+# Minimal makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line, and also
+# from the environment for the first two.
+SPHINXOPTS ?=
+SPHINXBUILD ?= sphinx-build
+SOURCEDIR = {{ rsrcdir }}
+BUILDDIR = {{ rbuilddir }}
+
+# Put it first so that "make" without argument is like "make help".
+help:
+ @$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+.PHONY: help Makefile
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+%: Makefile
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+