summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:23:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:23:11 +0000
commit26de5ed8d24188f544a9bc27cb7d86b641bceddf (patch)
tree7fbf5e1edc1e6b0fca9bda79edfe97168485ee26 /debian/rules
parentAdding upstream version 1:4.6.1. (diff)
downloadsquashfs-tools-debian.tar.xz
squashfs-tools-debian.zip
Adding debian version 1:4.6.1-1.debian/1%4.6.1-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..3618ad7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+export DEB_CFLAGS_MAINT_APPEND = -fgnu89-inline
+
+override_dh_auto_configure:
+ dh_auto_configure -- $(shell dpkg-buildflags --export=cmdline)
+
+override_dh_auto_build:
+ LZMA_XZ_SUPPORT=1 LZ4_SUPPORT=1 LZO_SUPPORT=1 XZ_SUPPORT=1 \
+ ZSTD_SUPPORT=1 dh_auto_build
+
+override_dh_auto_install:
+ dh_auto_install -- \
+ INSTALL_DIR=$(CURDIR)/debian/squashfs-tools/usr/bin \
+ INSTALL_MANPAGES_DIR=$(CURDIR)/debian/squashfs-tools/usr/share/man/man1
+
+%:
+ dh ${@} --sourcedirectory=squashfs-tools/
+
+.PHONY: override_dh_auto_build override_dh_auto_install