summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:07:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:07:52 +0000
commitbf1788da95239810dc3567dafb30666d0dc1526b (patch)
tree1d9f1f6d880ec90392377325cee23e9eed492322 /debian/rules
parentAdding upstream version 3.1.0. (diff)
downloadssh-audit-debian.tar.xz
ssh-audit-debian.zip
Adding debian version 3.1.0-1.debian/3.1.0-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..86f4c9d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+#export DH_VERBOSE = 1
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_configure:
+ dh_auto_configure
+
+override_dh_python3:
+ dh_python3 --shebang=/usr/bin/python3
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ PYTHONPATH=$(CURDIR)/src py.test-3
+endif
+
+override_dh_clean:
+ dh_clean $(CURDIR)/src/*.egg-info/