summaryrefslogtreecommitdiffstats
path: root/rust/vendor/alloc-stdlib/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
commita0aa2307322cd47bbf416810ac0292925e03be87 (patch)
tree37076262a026c4b48c8a0e84f44ff9187556ca35 /rust/vendor/alloc-stdlib/Cargo.toml
parentInitial commit. (diff)
downloadsuricata-a0aa2307322cd47bbf416810ac0292925e03be87.tar.xz
suricata-a0aa2307322cd47bbf416810ac0292925e03be87.zip
Adding upstream version 1:7.0.3.upstream/1%7.0.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'rust/vendor/alloc-stdlib/Cargo.toml')
-rw-r--r--rust/vendor/alloc-stdlib/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/rust/vendor/alloc-stdlib/Cargo.toml b/rust/vendor/alloc-stdlib/Cargo.toml
new file mode 100644
index 0000000..814e980
--- /dev/null
+++ b/rust/vendor/alloc-stdlib/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "alloc-stdlib"
+version = "0.2.2"
+authors = ["Daniel Reiter Horn <danielrh@dropbox.com>"]
+autobins = false
+description = "A dynamic allocator example that may be used with the stdlib"
+homepage = "https://github.com/dropbox/rust-alloc-no-stdlib"
+documentation = "https://raw.githubusercontent.com/dropbox/rust-alloc-no-stdlib/master/alloc-stdlib/tests/lib.rs"
+readme = "README.md"
+keywords = [
+ "custom",
+ "allocator",
+ "calloc",
+ "safe",
+ "nostd",
+]
+license = "BSD-3-Clause"
+repository = "https://github.com/dropbox/rust-alloc-no-stdlib"
+
+[[bin]]
+name = "example"
+
+[dependencies.alloc-no-stdlib]
+version = "2.0.4"
+
+[features]
+unsafe = []