summaryrefslogtreecommitdiffstats
path: root/rust/vendor/block-buffer/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
commita0aa2307322cd47bbf416810ac0292925e03be87 (patch)
tree37076262a026c4b48c8a0e84f44ff9187556ca35 /rust/vendor/block-buffer/Cargo.toml
parentInitial commit. (diff)
downloadsuricata-a0aa2307322cd47bbf416810ac0292925e03be87.tar.xz
suricata-a0aa2307322cd47bbf416810ac0292925e03be87.zip
Adding upstream version 1:7.0.3.upstream/1%7.0.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'rust/vendor/block-buffer/Cargo.toml')
-rw-r--r--rust/vendor/block-buffer/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/rust/vendor/block-buffer/Cargo.toml b/rust/vendor/block-buffer/Cargo.toml
new file mode 100644
index 0000000..4e50744
--- /dev/null
+++ b/rust/vendor/block-buffer/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "block-buffer"
+version = "0.10.4"
+authors = ["RustCrypto Developers"]
+description = "Buffer type for block processing of data"
+documentation = "https://docs.rs/block-buffer"
+readme = "README.md"
+keywords = [
+ "block",
+ "buffer",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/utils"
+
+[dependencies.generic-array]
+version = "0.14"