summaryrefslogtreecommitdiffstats
path: root/rust/vendor/itoa/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
commita0aa2307322cd47bbf416810ac0292925e03be87 (patch)
tree37076262a026c4b48c8a0e84f44ff9187556ca35 /rust/vendor/itoa/Cargo.toml
parentInitial commit. (diff)
downloadsuricata-a0aa2307322cd47bbf416810ac0292925e03be87.tar.xz
suricata-a0aa2307322cd47bbf416810ac0292925e03be87.zip
Adding upstream version 1:7.0.3.upstream/1%7.0.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'rust/vendor/itoa/Cargo.toml')
-rw-r--r--rust/vendor/itoa/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/rust/vendor/itoa/Cargo.toml b/rust/vendor/itoa/Cargo.toml
new file mode 100644
index 0000000..5173719
--- /dev/null
+++ b/rust/vendor/itoa/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.36"
+name = "itoa"
+version = "1.0.9"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+exclude = [
+ "performance.png",
+ "chart/**",
+]
+description = "Fast integer primitive to string conversion"
+documentation = "https://docs.rs/itoa"
+readme = "README.md"
+keywords = ["integer"]
+categories = [
+ "value-formatting",
+ "no-std",
+ "no-std::no-alloc",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/itoa"
+
+[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+doc-scrape-examples = false
+
+[dependencies.no-panic]
+version = "0.1"
+optional = true