summaryrefslogtreecommitdiffstats
path: root/rust/vendor/siphasher/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
commita0aa2307322cd47bbf416810ac0292925e03be87 (patch)
tree37076262a026c4b48c8a0e84f44ff9187556ca35 /rust/vendor/siphasher/Cargo.toml
parentInitial commit. (diff)
downloadsuricata-a0aa2307322cd47bbf416810ac0292925e03be87.tar.xz
suricata-a0aa2307322cd47bbf416810ac0292925e03be87.zip
Adding upstream version 1:7.0.3.upstream/1%7.0.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'rust/vendor/siphasher/Cargo.toml')
-rw-r--r--rust/vendor/siphasher/Cargo.toml57
1 files changed, 57 insertions, 0 deletions
diff --git a/rust/vendor/siphasher/Cargo.toml b/rust/vendor/siphasher/Cargo.toml
new file mode 100644
index 0000000..b0fbb87
--- /dev/null
+++ b/rust/vendor/siphasher/Cargo.toml
@@ -0,0 +1,57 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "siphasher"
+version = "0.3.11"
+authors = ["Frank Denis <github@pureftpd.org>"]
+description = "SipHash-2-4, SipHash-1-3 and 128-bit variants in pure Rust"
+homepage = "https://docs.rs/siphasher"
+documentation = "https://docs.rs/siphasher"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "hash",
+ "siphash",
+]
+categories = [
+ "algorithms",
+ "cryptography",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/jedisct1/rust-siphash"
+
+[profile.release]
+opt-level = 3
+lto = true
+panic = "abort"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+
+[features]
+default = ["std"]
+serde_no_std = ["serde/alloc"]
+serde_std = [
+ "std",
+ "serde/std",
+]
+std = []
+
+[badges.travis-ci]
+repository = "jedisct1/rust-siphash"