summaryrefslogtreecommitdiffstats
path: root/rust/vendor/synstructure/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:39:49 +0000
commita0aa2307322cd47bbf416810ac0292925e03be87 (patch)
tree37076262a026c4b48c8a0e84f44ff9187556ca35 /rust/vendor/synstructure/Cargo.toml
parentInitial commit. (diff)
downloadsuricata-a0aa2307322cd47bbf416810ac0292925e03be87.tar.xz
suricata-a0aa2307322cd47bbf416810ac0292925e03be87.zip
Adding upstream version 1:7.0.3.upstream/1%7.0.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'rust/vendor/synstructure/Cargo.toml')
-rw-r--r--rust/vendor/synstructure/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/rust/vendor/synstructure/Cargo.toml b/rust/vendor/synstructure/Cargo.toml
new file mode 100644
index 0000000..0339856
--- /dev/null
+++ b/rust/vendor/synstructure/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "synstructure"
+version = "0.12.6"
+authors = ["Nika Layzell <nika@thelayzells.com>"]
+include = ["src/**/*", "Cargo.toml", "README.md", "LICENSE"]
+description = "Helper methods and macros for custom derives"
+documentation = "https://docs.rs/synstructure"
+readme = "README.md"
+keywords = ["syn", "macros", "derive", "expand_substructure", "enum"]
+license = "MIT"
+repository = "https://github.com/mystor/synstructure"
+[dependencies.proc-macro2]
+version = "1"
+default-features = false
+
+[dependencies.quote]
+version = "1"
+default-features = false
+
+[dependencies.syn]
+version = "1"
+features = ["derive", "parsing", "printing", "clone-impls", "visit", "extra-traits"]
+default-features = false
+
+[dependencies.unicode-xid]
+version = "0.2"
+[dev-dependencies.synstructure_test_traits]
+version = "0.1"
+
+[features]
+default = ["proc-macro"]
+proc-macro = ["proc-macro2/proc-macro", "syn/proc-macro", "quote/proc-macro"]