summaryrefslogtreecommitdiffstats
path: root/debian/patches/fix-repeated-builds.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/fix-repeated-builds.patch')
-rw-r--r--debian/patches/fix-repeated-builds.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/patches/fix-repeated-builds.patch b/debian/patches/fix-repeated-builds.patch
new file mode 100644
index 0000000..c389a60
--- /dev/null
+++ b/debian/patches/fix-repeated-builds.patch
@@ -0,0 +1,16 @@
+Description: do not clean vendor directory on distclean
+ dh_auto_clean calls make distclean, which in the case of Suricata also
+ removes the vendor directory. This breaks repeated builds.
+Author: Sascha Steinbiss <satta@debian.org>
+Last-Update: 2018-12-26
+--- a/rust/Makefile.am
++++ b/rust/Makefile.am
+@@ -69,7 +69,7 @@
+ rm -f Cargo.lock
+
+ maintainer-clean-local:
+- rm -rf vendor gen
++ rm -rf gen
+
+ check:
+ CARGO_HOME="$(CARGO_HOME)" @rustup_home@ \