summaryrefslogtreecommitdiffstats
path: root/debian/patches/no-use-gnu.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/no-use-gnu.patch')
-rw-r--r--debian/patches/no-use-gnu.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/patches/no-use-gnu.patch b/debian/patches/no-use-gnu.patch
new file mode 100644
index 0000000..c6d12d9
--- /dev/null
+++ b/debian/patches/no-use-gnu.patch
@@ -0,0 +1,28 @@
+Description: Don't use __USE_GNU
+ __USE_GNU is a glibc-internal symbol.
+ AC_USE_SYSTEM_EXTENSIONS is the proper autoconf
+ way to enable extensions.
+Author: Adrian Bunk <bunk@debian.org>
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -6,6 +6,7 @@
+ AM_INIT_AUTOMAKE([tar-ustar subdir-objects])
+
+ AC_LANG([C])
++ AC_USE_SYSTEM_EXTENSIONS
+ LT_INIT
+ PKG_PROG_PKG_CONFIG
+
+--- a/src/suricata-common.h
++++ b/src/suricata-common.h
+@@ -33,9 +33,6 @@
+ #define TRUE 1
+ #define FALSE 0
+
+-#define _GNU_SOURCE
+-#define __USE_GNU
+-
+ #if defined(__clang_analyzer__)
+ /* clang analyzer acts as DEBUG_VALIDATION in some places, so
+ * force this so #ifdef DEBUG_VALIDATION code gets included */