summaryrefslogtreecommitdiffstats
path: root/rust/vendor/aead/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/aead/Cargo.toml')
-rw-r--r--rust/vendor/aead/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/rust/vendor/aead/Cargo.toml b/rust/vendor/aead/Cargo.toml
new file mode 100644
index 0000000..40fa376
--- /dev/null
+++ b/rust/vendor/aead/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "aead"
+version = "0.4.3"
+authors = ["RustCrypto Developers"]
+description = "Traits for Authenticated Encryption with Associated Data (AEAD) algorithms,\nsuch as AES-GCM as ChaCha20Poly1305, which provide a high-level API\n"
+documentation = "https://docs.rs/aead"
+readme = "README.md"
+keywords = ["crypto", "encryption"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/traits"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+[dependencies.blobby]
+version = "0.3"
+optional = true
+
+[dependencies.generic-array]
+version = "0.14"
+default-features = false
+
+[dependencies.heapless]
+version = "0.7"
+optional = true
+default-features = false
+
+[dependencies.rand_core]
+version = "0.6"
+optional = true
+
+[features]
+alloc = []
+dev = ["blobby"]
+std = ["alloc", "rand_core/std"]
+stream = []