summaryrefslogtreecommitdiffstats
path: root/rust/vendor/aes/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/aes/Cargo.toml')
-rw-r--r--rust/vendor/aes/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/rust/vendor/aes/Cargo.toml b/rust/vendor/aes/Cargo.toml
new file mode 100644
index 0000000..683aea8
--- /dev/null
+++ b/rust/vendor/aes/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "aes"
+version = "0.7.5"
+authors = ["RustCrypto Developers"]
+description = "Pure Rust implementation of the Advanced Encryption Standard (a.k.a. Rijndael)\nincluding support for AES in counter mode (a.k.a. AES-CTR)\n"
+documentation = "https://docs.rs/aes"
+readme = "README.md"
+keywords = ["crypto", "aes", "rijndael", "block-cipher"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/block-ciphers"
+[package.metadata.docs.rs]
+features = ["ctr"]
+rustdoc-args = ["--cfg", "docsrs"]
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.cipher]
+version = "0.3"
+
+[dependencies.ctr]
+version = "0.8"
+optional = true
+
+[dependencies.opaque-debug]
+version = "0.3"
+[dev-dependencies.cipher]
+version = "0.3"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.2"
+
+[features]
+armv8 = []
+compact = []
+force-soft = []
+hazmat = []
+[target."cfg(any(target_arch = \"aarch64\", target_arch = \"x86_64\", target_arch = \"x86\"))".dependencies.cpufeatures]
+version = "0.2"