summaryrefslogtreecommitdiffstats
path: root/rust/vendor/asn1-rs-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/asn1-rs-derive/Cargo.toml')
-rw-r--r--rust/vendor/asn1-rs-derive/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/rust/vendor/asn1-rs-derive/Cargo.toml b/rust/vendor/asn1-rs-derive/Cargo.toml
new file mode 100644
index 0000000..8dc4bad
--- /dev/null
+++ b/rust/vendor/asn1-rs-derive/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "asn1-rs-derive"
+version = "0.4.0"
+authors = ["Pierre Chifflier <chifflier@wzdftpd.net>"]
+description = "Derive macros for the `asn1-rs` crate"
+homepage = "https://github.com/rusticata/asn1-rs"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rusticata/asn1-rs.git"
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0"
+features = ["full"]
+
+[dependencies.synstructure]
+version = "0.12"