summaryrefslogtreecommitdiffstats
path: root/rust/vendor/der-oid-macro/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/der-oid-macro/Cargo.toml')
-rw-r--r--rust/vendor/der-oid-macro/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/rust/vendor/der-oid-macro/Cargo.toml b/rust/vendor/der-oid-macro/Cargo.toml
new file mode 100644
index 0000000..d7b4145
--- /dev/null
+++ b/rust/vendor/der-oid-macro/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "der-oid-macro"
+version = "0.5.0"
+authors = ["Pierre Chifflier <chifflier@wzdftpd.net>", "Jannik Schürg <schuerg@ins.uni-bonn.de>"]
+description = "Macro to encode DER oids at compile time"
+homepage = "https://github.com/rusticata/der-parser"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rusticata/der-parser.git"
+
+[lib]
+proc-macro = true
+[dependencies.num-bigint]
+version = "0.4"
+
+[dependencies.num-traits]
+version = "0.2"
+
+[dependencies.syn]
+version = "1.0"