summaryrefslogtreecommitdiffstats
path: root/rust/vendor/failure/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/failure/Cargo.toml')
-rw-r--r--rust/vendor/failure/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/rust/vendor/failure/Cargo.toml b/rust/vendor/failure/Cargo.toml
new file mode 100644
index 0000000..5a5dde0
--- /dev/null
+++ b/rust/vendor/failure/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "failure"
+version = "0.1.8"
+authors = ["Without Boats <boats@mozilla.com>"]
+description = "Experimental error handling abstraction."
+homepage = "https://rust-lang-nursery.github.io/failure/"
+documentation = "https://docs.rs/failure"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang-nursery/failure"
+[dependencies.backtrace]
+version = "0.3.3"
+optional = true
+
+[dependencies.failure_derive]
+version = "0.1.7"
+optional = true
+
+[features]
+default = ["std", "derive"]
+derive = ["failure_derive"]
+std = ["backtrace"]
+[badges.maintenance]
+status = "deprecated"