summaryrefslogtreecommitdiffstats
path: root/rust/vendor/nom-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/nom-derive/Cargo.toml')
-rw-r--r--rust/vendor/nom-derive/Cargo.toml56
1 files changed, 56 insertions, 0 deletions
diff --git a/rust/vendor/nom-derive/Cargo.toml b/rust/vendor/nom-derive/Cargo.toml
new file mode 100644
index 0000000..1374d3c
--- /dev/null
+++ b/rust/vendor/nom-derive/Cargo.toml
@@ -0,0 +1,56 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "nom-derive"
+version = "0.10.1"
+authors = ["Pierre Chifflier <chifflier@wzdftpd.net>"]
+include = [
+ "LICENSE-*",
+ "CHANGELOG.md",
+ "UPGRADING.md",
+ "README.md",
+ ".gitignore",
+ ".travis.yml",
+ "Cargo.toml",
+ "nom-derive-impl/Cargo.toml",
+ "nom-derive-impl/*.rs",
+ "src/*.rs",
+ "src/meta/*.rs",
+]
+description = "Custom derive nom parsers from struct"
+homepage = "https://github.com/rust-bakery/nom-derive"
+readme = "README.md"
+keywords = [
+ "parser",
+ "nom",
+]
+categories = ["parsing"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-bakery/nom-derive.git"
+
+[dependencies.nom]
+version = "7.0"
+features = ["std"]
+default-features = false
+
+[dependencies.nom-derive-impl]
+version = "=0.10.1"
+
+[dependencies.rustversion]
+version = "1.0"
+
+[dev-dependencies.pretty_assertions]
+version = "0.7"
+
+[dev-dependencies.trybuild]
+version = "1.0"