summaryrefslogtreecommitdiffstats
path: root/rust/vendor/num/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/num/Cargo.toml')
-rw-r--r--rust/vendor/num/Cargo.toml62
1 files changed, 62 insertions, 0 deletions
diff --git a/rust/vendor/num/Cargo.toml b/rust/vendor/num/Cargo.toml
new file mode 100644
index 0000000..f496f25
--- /dev/null
+++ b/rust/vendor/num/Cargo.toml
@@ -0,0 +1,62 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "num"
+version = "0.2.1"
+authors = ["The Rust Project Developers"]
+exclude = ["/ci/*", "/.travis.yml", "/bors.toml"]
+description = "A collection of numeric types and traits for Rust, including bigint,\ncomplex, rational, range iterators, generic integers, and more!\n"
+homepage = "https://github.com/rust-num/num"
+documentation = "https://docs.rs/num"
+readme = "README.md"
+keywords = ["mathematics", "numerics", "bignum"]
+categories = ["algorithms", "data-structures", "science", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-num/num"
+[package.metadata.docs.rs]
+features = ["std", "serde", "rand"]
+[dependencies.num-bigint]
+version = "0.2.5"
+optional = true
+default-features = false
+
+[dependencies.num-complex]
+version = "0.2.4"
+default-features = false
+
+[dependencies.num-integer]
+version = "0.1.42"
+default-features = false
+
+[dependencies.num-iter]
+version = "0.1.40"
+default-features = false
+
+[dependencies.num-rational]
+version = "0.2.3"
+default-features = false
+
+[dependencies.num-traits]
+version = "0.2.11"
+default-features = false
+
+[dev-dependencies]
+
+[features]
+default = ["std"]
+i128 = ["num-bigint/i128", "num-complex/i128", "num-integer/i128", "num-iter/i128", "num-rational/i128", "num-traits/i128"]
+rand = ["num-bigint/rand", "num-complex/rand"]
+serde = ["num-bigint/serde", "num-complex/serde", "num-rational/serde"]
+std = ["num-bigint/std", "num-complex/std", "num-integer/std", "num-iter/std", "num-rational/std", "num-rational/bigint", "num-traits/std"]
+[badges.travis-ci]
+repository = "rust-num/num"