summaryrefslogtreecommitdiffstats
path: root/rust/vendor/num_threads/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/num_threads/Cargo.toml')
-rw-r--r--rust/vendor/num_threads/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/rust/vendor/num_threads/Cargo.toml b/rust/vendor/num_threads/Cargo.toml
new file mode 100644
index 0000000..abfb41e
--- /dev/null
+++ b/rust/vendor/num_threads/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "num_threads"
+version = "0.1.6"
+authors = ["Jacob Pratt <open-source@jhpratt.dev>"]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+]
+description = "A minimal library that determines the number of running threads for the current process."
+categories = [
+ "api-bindings",
+ "hardware-support",
+ "os",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/jhpratt/num_threads"
+
+[package.metadata.docs.rs]
+all-features = true
+targets = ["x86_64-unknown-linux-gnu"]
+
+[dependencies]
+
+[target."cfg(any(target_os = \"macos\", target_os = \"ios\", target_os = \"freebsd\"))".dependencies.libc]
+version = "0.2.107"