summaryrefslogtreecommitdiffstats
path: root/rust/vendor/oid-registry/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/oid-registry/Cargo.toml')
-rw-r--r--rust/vendor/oid-registry/Cargo.toml68
1 files changed, 68 insertions, 0 deletions
diff --git a/rust/vendor/oid-registry/Cargo.toml b/rust/vendor/oid-registry/Cargo.toml
new file mode 100644
index 0000000..fa1cdb1
--- /dev/null
+++ b/rust/vendor/oid-registry/Cargo.toml
@@ -0,0 +1,68 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "oid-registry"
+version = "0.6.1"
+authors = ["Pierre Chifflier <chifflier@wzdftpd.net>"]
+build = "build.rs"
+include = [
+ "LICENSE-*",
+ "README.md",
+ ".gitignore",
+ "Cargo.toml",
+ "assets/*.txt",
+ "build.rs",
+ "src/*.rs",
+]
+description = "Object Identifier (OID) database"
+homepage = "https://github.com/rusticata/oid-registry"
+readme = "README.md"
+keywords = [
+ "BER",
+ "DER",
+ "OID",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rusticata/oid-registry.git"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.asn1-rs]
+version = "0.5"
+
+[features]
+crypto = [
+ "kdf",
+ "pkcs1",
+ "pkcs7",
+ "pkcs9",
+ "pkcs12",
+ "nist_algs",
+ "x962",
+]
+default = ["registry"]
+kdf = []
+ms_spc = []
+nist_algs = []
+pkcs1 = []
+pkcs12 = []
+pkcs7 = []
+pkcs9 = []
+registry = []
+x509 = []
+x962 = []