summaryrefslogtreecommitdiffstats
path: root/rust/vendor/proc-macro-crate/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/proc-macro-crate/Cargo.toml')
-rw-r--r--rust/vendor/proc-macro-crate/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/rust/vendor/proc-macro-crate/Cargo.toml b/rust/vendor/proc-macro-crate/Cargo.toml
new file mode 100644
index 0000000..03f0bfe
--- /dev/null
+++ b/rust/vendor/proc-macro-crate/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "proc-macro-crate"
+version = "1.1.0"
+authors = ["Bastian Köcher <git@kchr.de>"]
+description = "Replacement for crate (macro_rules keyword) in proc-macros\n"
+documentation = "https://docs.rs/proc-macro-crate"
+readme = "./README.md"
+keywords = ["macro-rules", "crate", "macro", "proc-macro"]
+categories = ["development-tools::procedural-macro-helpers"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/bkchr/proc-macro-crate"
+[dependencies.thiserror]
+version = "1.0.24"
+
+[dependencies.toml]
+version = "0.5.2"
+[dev-dependencies.proc-macro2]
+version = "1.0.18"
+
+[dev-dependencies.quote]
+version = "1.0.7"
+
+[dev-dependencies.syn]
+version = "1.0.33"