summaryrefslogtreecommitdiffstats
path: root/rust/vendor/test-case/publish.sh
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/test-case/publish.sh')
-rwxr-xr-xrust/vendor/test-case/publish.sh24
1 files changed, 24 insertions, 0 deletions
diff --git a/rust/vendor/test-case/publish.sh b/rust/vendor/test-case/publish.sh
new file mode 100755
index 0000000..e2710bf
--- /dev/null
+++ b/rust/vendor/test-case/publish.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+cargo clippy --all-targets --all-features -- -D warnings
+cargo fmt --all
+cargo test --all --all-features
+
+nvim Cargo.toml
+cargo build
+
+nvim CHANGELOG.md
+nvim src/lib.rs
+
+cargo readme > README.md
+
+cargo publish --dry-run --allow-dirty
+
+git add .
+git commit
+git push origin
+
+echo "Next step: Wait for CI"
+echo "Next step: \`git tag vX.Y.Z; git push --tags\`"
+echo "Next step: Create release in Github"
+echo "Next step: \`cargo publish\`"