summaryrefslogtreecommitdiffstats
path: root/rust/vendor/tls-parser/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/tls-parser/Cargo.toml')
-rw-r--r--rust/vendor/tls-parser/Cargo.toml66
1 files changed, 66 insertions, 0 deletions
diff --git a/rust/vendor/tls-parser/Cargo.toml b/rust/vendor/tls-parser/Cargo.toml
new file mode 100644
index 0000000..6b9b48e
--- /dev/null
+++ b/rust/vendor/tls-parser/Cargo.toml
@@ -0,0 +1,66 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "tls-parser"
+version = "0.11.0"
+authors = ["Pierre Chifflier <chifflier@wzdftpd.net>"]
+build = "build.rs"
+include = ["LICENSE-*", ".gitignore", ".travis.yml", "Cargo.toml", "benches/*.rs", "build.rs", "src/*.rs", "tests/*.rs", "scripts/tls-ciphersuites.txt", "scripts/extract-iana-ciphers.py"]
+description = "Parser for the TLS protocol"
+homepage = "https://github.com/rusticata/tls-parser"
+documentation = "https://docs.rs/tls-parser"
+readme = "README.md"
+keywords = ["TLS", "SSL", "protocol", "parser", "nom"]
+categories = ["network-programming", "parser-implementations"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rusticata/tls-parser.git"
+
+[lib]
+name = "tls_parser"
+[dependencies.cookie-factory]
+version = "0.3"
+optional = true
+
+[dependencies.enum_primitive]
+version = "^0.1"
+
+[dependencies.nom]
+version = "7.0"
+
+[dependencies.nom-derive]
+version = "0.10"
+
+[dependencies.phf]
+version = "0.10"
+
+[dependencies.rusticata-macros]
+version = "4.0"
+[dev-dependencies.clap]
+version = "~2.33"
+default-features = false
+
+[dev-dependencies.hex-literal]
+version = "0.3"
+
+[dev-dependencies.pretty_assertions]
+version = "0.7"
+[build-dependencies.phf_codegen]
+version = "0.10"
+
+[features]
+default = ["std"]
+serialize = ["cookie-factory"]
+std = []
+unstable = []
+[badges.travis-ci]
+repository = "rusticata/tls-parser"