summaryrefslogtreecommitdiffstats
path: root/rust/vendor/universal-hash/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/vendor/universal-hash/Cargo.toml')
-rw-r--r--rust/vendor/universal-hash/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/rust/vendor/universal-hash/Cargo.toml b/rust/vendor/universal-hash/Cargo.toml
new file mode 100644
index 0000000..b2f27b0
--- /dev/null
+++ b/rust/vendor/universal-hash/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "universal-hash"
+version = "0.4.1"
+authors = ["RustCrypto Developers"]
+description = "Trait for universal hash functions"
+documentation = "https://docs.rs/universal-hash"
+readme = "README.md"
+keywords = ["crypto", "mac"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/traits"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.generic-array]
+version = "0.14"
+
+[dependencies.subtle]
+version = "=2.4"
+default-features = false
+
+[features]
+std = []