summaryrefslogtreecommitdiffstats
path: root/.packit.yml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /.packit.yml
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.packit.yml')
-rw-r--r--.packit.yml61
1 files changed, 61 insertions, 0 deletions
diff --git a/.packit.yml b/.packit.yml
new file mode 100644
index 0000000..ada6f8b
--- /dev/null
+++ b/.packit.yml
@@ -0,0 +1,61 @@
+---
+# vi:ts=2 sw=2 et:
+#
+# Docs: https://packit.dev/docs/
+
+specfile_path: .packit_rpm/systemd.spec
+files_to_sync:
+ - .packit.yml
+ - src: .packit_rpm/systemd.spec
+ dest: systemd.spec
+upstream_package_name: systemd
+downstream_package_name: systemd
+# `git describe` returns in systemd's case 'v245-xxx' which breaks RPM version
+# detection (that expects 245-xxxx'). Let's tweak the version string accordingly
+upstream_tag_template: "v{version}"
+srpm_build_deps: []
+
+actions:
+ get-current-version:
+ # Show the closest matching tag for the checked out revision, otherwise
+ # Packit tries to get the latest tag by creation date, which doesn't work
+ # well in the systemd-stable repo. We also need to sanitize it manually
+ # since "upstream_tag_template" defined above doesn't apply here.
+ - "bash -ec 'git describe --tags --abbrev=0 | cut -b 2-'"
+
+ post-upstream-clone:
+ # Use the Fedora Rawhide specfile
+ - "git clone https://src.fedoraproject.org/rpms/systemd .packit_rpm --depth=1"
+ # Drop the "sources" file so rebase-helper doesn't think we're a dist-git
+ - "rm -fv .packit_rpm/sources"
+ # Drop backported patches from the specfile, but keep the downstream-only ones
+ # - Patch(0000-0499): backported patches from upstream
+ # - Patch0500-9999: downstream-only patches
+ - "sed -ri '/^Patch(0[0-4]?[0-9]{0,2})?\\:.+\\.patch/d' .packit_rpm/systemd.spec"
+ # Build the RPM with --werror. Even though --werror doesn't work in all
+ # cases (see [0]), we can't use -Dc_args=/-Dcpp_args= here because of the
+ # RPM hardening macros, that use $CFLAGS/$CPPFLAGS (see [1]).
+ #
+ # [0] https://github.com/mesonbuild/meson/issues/7360
+ # [1] https://github.com/systemd/systemd/pull/18908#issuecomment-792250110
+ - 'sed -i "/^CONFIGURE_OPTS=(/a--werror" .packit_rpm/systemd.spec'
+ # Ignore unpackages standalone binaries
+ - "sed -i 's/assert False,.*/pass/' .packit_rpm/split-files.py"
+
+jobs:
+- job: copr_build
+ trigger: pull_request
+ targets:
+ - fedora-rawhide-aarch64
+ - fedora-rawhide-i386
+ - fedora-rawhide-ppc64le
+ - fedora-rawhide-s390x
+ - fedora-rawhide-x86_64
+
+- job: tests
+ trigger: pull_request
+ fmf_url: https://src.fedoraproject.org/tests/systemd
+ fmf_ref: main
+ tmt_plan: ci
+ targets:
+ - fedora-rawhide-x86_64