summaryrefslogtreecommitdiffstats
path: root/catalog/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:49:52 +0000
commit55944e5e40b1be2afc4855d8d2baf4b73d1876b5 (patch)
tree33f869f55a1b149e9b7c2b7e201867ca5dd52992 /catalog/meson.build
parentInitial commit. (diff)
downloadsystemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.tar.xz
systemd-55944e5e40b1be2afc4855d8d2baf4b73d1876b5.zip
Adding upstream version 255.4.upstream/255.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'catalog/meson.build')
-rw-r--r--catalog/meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/catalog/meson.build b/catalog/meson.build
new file mode 100644
index 0000000..3c62749
--- /dev/null
+++ b/catalog/meson.build
@@ -0,0 +1,38 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+in_files = [
+ 'systemd.be.catalog',
+ 'systemd.be@latin.catalog',
+ 'systemd.bg.catalog',
+ 'systemd.catalog',
+ 'systemd.da.catalog',
+ 'systemd.de.catalog',
+ 'systemd.fr.catalog',
+ 'systemd.hr.catalog',
+ 'systemd.hu.catalog',
+ 'systemd.it.catalog',
+ 'systemd.ko.catalog',
+ 'systemd.pl.catalog',
+ 'systemd.pt_BR.catalog',
+ 'systemd.ru.catalog',
+ 'systemd.sr.catalog',
+ 'systemd.zh_CN.catalog',
+ 'systemd.zh_TW.catalog',
+]
+
+support_url = get_option('support-url')
+support_sed = 's~%SUPPORT_URL%~@0@~'.format(support_url)
+
+foreach file : in_files
+ catalogs += custom_target(
+ file,
+ input : file + '.in',
+ output: file,
+ command : [sed, support_sed, '@INPUT@'],
+ capture : true,
+ install : true,
+ install_dir : catalogdir)
+endforeach
+
+meson.add_install_script(sh, '-c',
+ 'test -n "$DESTDIR" || @0@/journalctl --update-catalog'.format(bindir))